Login - Create Account

Batch GUI Tool for Windows

Messages 91 - 135 of 234
First | Prev. | 1 2 3 4 5 | Next | Last 
Login or Register to post new topics or replies
Indigo Ray
Adam

Posts: 1339
Filters: 79
Tested the new version out. It's got a node-based interface! Reminds me of this program...what's it called again... smile;)

2 bugs / user errors (?)

1. I run the batch fine, but I still can't click on "create animated GIF"
2. I connect two filters in a linear chain, but it renders both the full chain and the output of the first filter only. I only wanted the full chain.
...or something like that.
  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
Quote
aba

I uploaded a new version with a completely different GUI. Hope you like it and I hope that I didn't introduce new bugs ...

Stacking of filters should be very easy now.

Please don't use the older version anymore and try/test/use this one.

Comments / suggestions are welcome...

You can find it at: Filter Forge Batch Tool Download Page


WOW!!! I can´t believe yet that you have been able to make a totally new GUI that is NODE BASED and is very well done and clean

I have seen that to modify the node of each filter you only have to double click over it and it will appear a new small window with options, and this is a very good idea and way to do it. I also like that when you click over a node it changes the color, so you can know that you have selected that node.

What I do not like much is that when selecting any node it converts the node to orange color, and so I want to ask if there could be any possible way to configure in the preferences this color and make it a custom color, instead of only orange always.

  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
I have found a bug

1 - Select Add filter and then go back to filter stack so it shows the node there
2 - Select now Insert filter and choose another filter
3 - When you try to go back to Filter Stack I get this error message shown below
4 - If you click continue, all the filters nodes are cleared, and the output directory is missing also.

  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
Another bug I have found is that now the small default window with that new awesome and amazing node based filters can become cluttered easily, so you would need to expand the window and make it bigger to have more space, BUT then I have found a problem, all the right menu is broken and dissappears except the central part.

1 - Open the tool and load a filter
2 - Go to any corner of the window and try to resize it
3 - You will see that the right menu is broken and dissappears

  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
And if you make it more smaller than the original default size, then happens this shown below

  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
FILTER NODE APPEARS OUTSIDE

One weird thing is that if the window is already filled with nodes, and then you want to add another filter node more, it will appear outside of the viewable space (outside of the visible window) and this is not bad if you could resize the window without getting the menu broken

1 - Put four or more filters nodes inside the default size window
2 - Add another filter node more, and most probably that it would appear outside of the visible window

  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
If after this one above you still keep adding more filters nodes, they will appear after the last one, also outside of visible window, so if you expand the window you will see them

This is really not a problem and not something wrong, IF you could expand the window and find them there and you can reorganize them as you want

  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
DELETED LINKS WILL BE BACK AGAIN

I have also seen that if you delete the links of one node, and it is left out, then if you add another filter, when the new filter node appears, the deleted links will be back again and shown as if you did not delete them before.

  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
In the same way, if you connect any of the possible additional links of a filter node to the output directory and then you want to delete them, they will appear again when you add a new filter node

  Details E-Mail
aba
Batchman
Posts: 95
Hi SpaceRay,
did you try to expand/zoom-out with the scroll wheel of your mouse?
  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
As much as I test it, I am loving it more and find it really awesome and never expected to have something as wonderful as this that you have done.

And the feature to be able to zoom in-out all the stack is really great and very useful and works very smoothly

I suposse that the filter nodes only can have one link from the source and the only way to combine them is by Insert Filter

And the only node that can have more than one source is the output directory node

I will keep testing and tell what I can find

Congratulations and thanks very much for making this new node based version
  Details E-Mail
aba
Batchman
Posts: 95
Thanks! It was a lot work to program this, but it makes the tool more useful for complex stacks I think. It was rather complex, so I expect that it has a few bugs, but they can be solved.

The intention was that a input node only has one input, but that a output node/map can be connected to more input-nodes.

You can only connect from filter 1 to 2...99, not from 2 to 1.

I will first look at the re-apearing links- connections to the output node. It was intentional to let the image output link re-appear, but not the other maps.

Would it be more logical to let a new filter node appear on a fixed location?
  Details E-Mail
aba
Batchman
Posts: 95
@Indigo Ray
Thanks for testing!
Quote
2 bugs / user errors (?)

1. I run the batch fine, but I still can't click on "create animated GIF"
2. I connect two filters in a linear chain, but it renders both the full chain and the output of the first filter only. I only wanted the full chain.

Did you choose two presets and a number of images between two presets? There must be something to make the animation over. What do you mean by "can't click on"?
It is possible that the Tool didn't work with your second filter. Which filters did you use? Can you explain a bit more?
  Details E-Mail
aba
Batchman
Posts: 95
Hi, I uploaded a new version (0.92)

hopefully fixed:
Quote
1 - Sel ect Add filter and then go back to filter stack so it shows the node there
2 - Select now Insert filter and choose another filter
3 - When you try to go back to Filter Stack I get this error message shown below
4 - If you click continue, all the filters nodes are cleared, and the output directory is missing also.

thanks to SpaceRay

and an other bug I found myself.

I locked the window-size, that was indeed confusing. Only use the mouse wheel to zoom. Maybe I'll let it automatically zoom out in a later version.

There was no need to show the focus/selected state of a node, so I got rid of that orange, it's only usefull for selecting the connections.

Quote
In the same way, if you connect any of the possible additional links of a filter node to the output directory and then you want to delete them, they will appear again when you add a new filter node

I can't reproduce the re-appearing links (other than fr om the image-node, but that's intentional).

and a off-topic question: how do you upload an image so that it can be seen in the message?
  Details E-Mail
Sharandra
Filter Forge Addict

Posts: 863
Filters: 26
Hey Aba, like your new design smile:-)

I have some trouble with image transparency for PNGs tho, that doesn´t seem to work at all. I either get blank images or white backgrounds.
  Details E-Mail
Indigo Ray
Adam

Posts: 1339
Filters: 79
Quote
Did you choose two presets and a number of images between two presets? There must be something to make the animation over. What do you mean by "can't click on"?
It is possible that the Tool didn't work with your second filter. Which filters did you use? Can you explain a bit more?


OK, I can make an animated gif now, the option was grayed out before...not sure what I did differently.

And never mind about the other point. The extra renders I was seeing are actually intermediate steps in the chain (I can't apply dither to the candle if I don't render the candle first).

I'm excited to try out more combinations. Thanks for your wonderful work!

...or something like that.
  Details E-Mail
aba
Batchman
Posts: 95
@Indigo Ray: I'm glad it works now!

@Sharandra
Quote
I have some trouble with image transparency for PNGs tho, that doesn´t seem to work at all. I either get blank images or white backgrounds.

This seems to be a "feature" of the batch renderer. The batch.xml is oke, but it doesn't create transparent images. In the forums I read a workaround:
Quote
had to specify a fully transparent source file otherwise it only rendered the filter over a white background. I'm using FFBatchMaster for Mac OS X. I also had to make the source transparent file the same dimensions that I wanted to render the final out to,


I implemented that workaround (let the tool create that transparent image on texture size and use that as input, and use that image in case of texture rendering automaticcaly). The side effect is that you'll get a black background when you choose not to Include Transparency in the Image output format instead of white. Maybe I'll look into that if somebody has problems with this.

New version uploaded (v0.93) with transparent image fix.
  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
I like how you can use multiple sources when you have color controls for the filter

And what is impossible in FF is that you can load a directory of images inside one color control setting of a filter, and with this tool you can do it smile:)

Although the only thing I see that maybe is not so much friendly and good is that if have more than one source images like this below, all of them have the same name of "single images" or "directory images" or "texture" but unless you click over the icon to open that node and see what is inside you can´t know what is included in each one from outside. I mean maybe if it could be possible that when you hover the mouse over each source it could tell you the name of the file, or the name of the folder.

Perhaps I am being too picky with this, and really maybe is not needed as there is really very few filters that need more than 2 or 3 color controls, so really this would not be really important, and do not want that you spend time on this and work more.

  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
I like much that when selecting a source of directory of images, you can click on it and it will open a full list with the name of each one and the resolution size

Thanks very much for adding this

The only possible problem I see, is that most of my images and photos does not have a meaningfull name, and is like DSC_0895, so you do not know the image by the name, although if you have already loaded it, you really must know what you have loaded, and know what this images are refering too. So again I am probably being too picky.

  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
I like much that if you click on a link to be connected, the possible destiny points availables will be highlighted in red and then ones not possible to use will become grey. Well done and great.

  Details E-Mail
aba
Batchman
Posts: 95
Hi SpaceRay.
Quote
all of them have the same name of "single images" or "directory images" or "texture" but unless you click over the icon to open that node and see what is inside you can´t know what is included in each one from outside. I mean maybe if it could be possible that when you hover the mouse over each source it could tell you the name of the file, or the name of the folder.

Sorry but that's to much smile:) I don't know a way to implement that in a nice way. You can always click on the Info button, that will give you insight in all the used sources per filter/input etc.

Quote
The only possible problem I see, is that most of my images and photos does not have a meaningfull name, and is like DSC_0895, so you do not know the image by the name, although if you have already loaded it, you really must know what you have loaded, and know what this images are refering too.

If you select single images you can select the images you want with the windows-explorer, than you can see all the tumbnails.

Quote
I like much that if you click on a link to be connected, the possible destiny points availables will be highlighted in red and then ones not possible to use will become grey. Well done and great.

Thanks!
  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
Insert Filter does not work as expected, as it is exactly the same as "Add filter" and to be able to link or insert two filters you have to do it manually.

1 - Select add filter to choose one filter and add the first filter node

2 - Select Insert filter to be able to stack the next choosen filter to the previous filter

3 - When you choose this filter, instead of inserting it, it will just add it as if it was a new filter node

----------------------

To better show this

1 - Select add filter to choose one filter and add the first filter node

2 - Select add filter again to choose a second filter and add another node

3 - Select Insert filter to be able to put the third filter in between of the previous two filters, and then when going to filter stack, it will not show in the middle, it will be added as a new filter.

  Details E-Mail
aba
Batchman
Posts: 95
Quote
Select Insert filter to be able to put the third filter in between of the previous two filters, and then when going to filter stack, it will not show in the middle, it will be added as a new filter.

The only difference between inserting a filter or adding a filter is the number in the stack. You inserted Catwalk (I suppose) and it has stack number 02, so you can connect the output to nr 03 ChromeGrille. It will not automatically reconnect in/output, that must be done by hand.
But if you choose add it would be filter 03, you could connect ChromeGrille to Catwalk then.
I'm afraid that automatically reconnecting when inserting a filter in the stack could mess things up in more complicated stacks.
  Details E-Mail
Sharandra
Filter Forge Addict

Posts: 863
Filters: 26
thx aba, works perfect now smile:-)

Is it somehow possible, to let it render the same preset, but with different settings?
  Details E-Mail
aba
Batchman
Posts: 95
Quote
Is it somehow possible, to let it render the same preset, but with different settings?

It would be possible to build that into the program, but I think it's better done in FF. Where would you use it for?
1) It is possible to create two presets with the maximum difference that you want for a slider (say one preset 1 and the other preset value 100). Then set animation number of images between two presets at 98, and then choose render only one step. If you choose step 25 it will render the image with slider value 25. I use that for a simple filter that (with Minimum/Maximum Level) sets the maximum contrast, and in the filterstack I can choose a contrast value.
2) reading again I think you want to use different rendering options. No only AntiAlias wil be a part of the animation, so you could make two exacty the same preferences with different AA and then animate over it. If you "need" an other setting to use that way, let me know.
  Details E-Mail
GMM
Moderator
Filter Forge, Inc
Posts: 2877
Quote
batch render them, will the filter author get credit for it?


Unfortunately not, and there are no plans to add this functionality. I admit this this unfair though.
  Details E-Mail
Sharandra
Filter Forge Addict

Posts: 863
Filters: 26
No, I don´t want to use different render options.

For example I have a filter that generates map tiles. It has several sliders which control what kind of tile piece will be created, for example corners and crossings and their directions. It would be great if you could batch render out all the combinations, without having to create a preset for each.

And another bug: It won´t open a filter if it loads external images in the color control.

Quote
Object reference not set to an instance of an object


Code
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
   at FFBatchTool.Filter.<ReadControls>b__b(XElement c)
   at System.Linq.Enumerable.WhereSelectEnumerableIterator`2.MoveNext()
   at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
   at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
   at FFBatchTool.Filter.ReadControls(Settings settings)
   at FFBatchTool.Filter.ReadFilter(Settings settings)
   at FFBatchTool.Filter..ctor(String filterPath, Settings settings)
   at FFBatchTool.FFBatchTool.FilterSelectionDataGridView_CellContentClick(Object sender, DataGridViewCellEventArgs e)
   at System.Windows.Forms.DataGridView.OnCellContentClick(DataGridViewCellEventArgs e)
   at System.Windows.Forms.DataGridView.OnCommonCellContentClick(Int32 columnIndex, Int32 rowIndex, Boolean doubleClick)
   at System.Windows.Forms.DataGridViewCell.OnMouseUpInternal(DataGridViewCellMouseEventArgs e)
   at System.Windows.Forms.DataGridView.OnCellMouseUp(DataGridViewCellMouseEventArgs e)
   at System.Windows.Forms.DataGridView.OnMouseUp(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.DataGridView.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1008 (RTMGDR.030319-1000)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
FFBatchTool
    Assembly Version: 0.0.0.1
    Win32 Version: 0.0.0.1
    CodeBase: file:///C:/Users/Firedragon/Desktop/FFBatchTool.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1002 built by: RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1001 built by: RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1001 built by: RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1015 built by: RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1015 (RTMGDR.030319-1000)
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
wzflaoiz
    Assembly Version: 0.0.0.1
    Win32 Version: 4.0.30319.1001 built by: RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Xml.Linq
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.233 built by: RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


  Details E-Mail
Sharandra
Filter Forge Addict

Posts: 863
Filters: 26
Oh and btw GMM, I think you should hand out reward points to ppl who make tools like this. Aba made something we have been asking for for years, and he is doing an amazing job with it, so it would be only fair if he gets a reward for that. smile:-)
  Details E-Mail
aba
Batchman
Posts: 95
Quote
For example I have a filter that generates map tiles. It has several sliders which control what kind of tile piece will be created, for example corners and crossings and their directions. It would be great if you could batch render out all the combinations, without having to create a preset for each.

No, I'm sorry, that would be too difficult too implement and to use. You can animate over intSliders if you use the right number of steps, but making combinations of all sliders would complicate things too much.
Maybe I can try to implement a checkbox on the filterinfo page and let it render all possible int values for a intSlider. And all combinations if there are more than one. I will put it on a todo list..[edit: sorry, I would like it myself but I tried it and it gets too complicated smile:(]

Quote
It won´t open a filter if it loads external images in the color control.

That's strange, I have tried it with existing and non existing images, never had a problem, is it only on a specific filter?

Quote
so it would be only fair if he gets a reward for that

smile:) Thanks for your remark, I already asked for a discount on the update to FF4, but the FF team responded that I should ask the filerforge users for money to use my tool. In the meanwhile I payed for the FF4 update and as I started this "project" I said it would be free, so it will be free to use.
  Details E-Mail
Sharandra
Filter Forge Addict

Posts: 863
Filters: 26
It seems to be only a specific filter and all of it´s versions that load images. I guess something else causes the error then.

How do you animate over an intSlider?
  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
Quote
aba
New version uploaded (v0.93) with transparent image fix.


I have tested it with texture filters that include transparency and also loading PNG files with transparent background and it works well now and there is no problem.

NOT ALL THE FILTERS CAN HANDLE TRANSPARENCY


Must be said also that not all the filter can use images with transparent background while KEEPING that transparency in the result, as these will load right but the result will become a solid color. The filter must have been prepared by the author so that it supports alpha channel and it can process right any image with transparent background.


Quote
Insert Filter question

Sel ect Insert filter to be able to put the third filter in between of the previous two filters, and then when going to filter stack, it will not show in the middle, it will be added as a new filter.

The only difference between inserting a filter or adding a filter is the number in the stack. You inserted Catwalk (I suppose) and it has stack number 02, so you can connect the output to nr 03 ChromeGrille. It will not automatically reconnect in/output, that must be done by hand.

But if you choose add it would be filter 03, you could connect ChromeGrille to Catwalk then.


Yes, I used the insert filter with the Catwalk filter

OH! Sorry That I have not seen that the Catwalk filter has changed the node number fr om 3 to 2 that shows then that the Insert filter really works right. I see and now understand, and now know that is working right as it was made and I was wrong thinking that the insert filter would automatically link and position the filter between both filters.

So then the insert filter works changing the node number so when going to the batch rendering, it will do all the tasks according to these node number and in that order, and I think that this is right and a good thing.

Quote
aba
I'm afraid that automatically reconnecting when inserting a filter in the stack could mess things up in more complicated stacks.


I have to say that I do not need or want to have automatically reconnecting of the nodes, and I can easily and without problem do it manually and is OK. I have only told it BECAUSE I thought that this was the right it should work, but I was wrong and it does not work this way, so everything works fine and right with "add filter and Insert filter"

Quote
GMM
Quote
batch render them, will the filter author get credit for it?


Unfortunately not, and there are no plans to add this functionality. I admit this this unfair though


Well, I wish it could give credit, but you can´t have everything as you want, and maybe it would be bad if it was possible, because if you batch render a 2000 images at once, the credit reward would skyrocket, and then the HU rewards would skyrocket too, and then it would not be fair for FF Inc.
  Details E-Mail
aba
Batchman
Posts: 95
@Sharandra
Quote
It seems to be only a specific filter and all of it´s versions that load images. I guess something else causes the error then.

If you attach the filter I can look at it, maybe there are more filters with the same problem.
Quote
How do you animate over an intSlider?

Just make two presets with only a change in the intSlider. Select those two in preset tab en set images between to the correct number. If the first pref. has value 1, and the second 10 then there must be ((10 -1) -1 = ) 8 images in between. That's all.
  Details E-Mail
Sharandra
Filter Forge Addict

Posts: 863
Filters: 26
Will send it in an email because I don´t want to publish it right now. Maybe it will also help you to add support for batching those kind of filters smile;-)

Edit: Ah crap, can´t attach anything to a PM smile:-(
  Details E-Mail
aba
Batchman
Posts: 95
Hi sharandra, you could copy/paste the xml in the mail
  Details E-Mail
Sharandra
Filter Forge Addict

Posts: 863
Filters: 26
ok smile:-)
  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
To be able to test this tool fully and in better organized way and do not miss anything in the way I have made this chart with Google Drive Spreadsheet

So now in the weekend I will make all these tests that are shown and will fill this chart with the results I get and see then if all works right.

  Details E-Mail
aba
Batchman
Posts: 95
@Sharandra
Could you attach it to a pm, if I create a xml out your mail it will not read into FF (eror message smile:().
I can see that it uses groups and customClasses, I haven't tried that with the tool before, maybe that's the problem.

@SpaceRay: Great! smile:)
  Details E-Mail
Sharandra
Filter Forge Addict

Posts: 863
Filters: 26
Edit: nvmd smile:-)
  Details E-Mail
Mardar
Graphics Junkie

Posts: 668
Filters: 58
GMM thanks for the info. It's to bad the author will not get credit for renders. I guess I'll just continue to render my tiles one at a time while using others filters because I feel they need to get those credits. It's an ethical thing for me. I will only use my own filters for batch render through the program.

Quote
Well, I wish it could give credit, but you can´t have everything as you want, and maybe it would be bad if it was possible, because if you batch render a 2000 images at once, the credit reward would skyrocket, and then the HU rewards would skyrocket too, and then it would not be fair for FF Inc


No you are wrong. I have rendered hundreds of tiles through several of the filters in the library one at a time and the original builder reaped their just reward for it. Now there is a potential for new filter builders to have hundreds or thousands of tiles and renders stripped from their count and they will never get credit for it. So I see no harm coming to Filter Forge. I only see Filter Forge giving less HU then ever. smile:(
  Details E-Mail
aba
Batchman
Posts: 95
New version available (beta 0.94)

It has a bugfix for FF4 beta and a new option: you can render all values of one intSlider of (one or more) preset(s). You can find that on the presets tab (it is instead of animation, that does not work together).

@Sharandra: I think that FF4 creates nameless duplicate controls in the filter xml when grouping and ungrouping. Did not spend time to find the cause but the batch-tool should now work properly on your filter (and other filters with the same artefacts). Thanks and hope to see your filter in the library someday.

Happy testing smile:)
  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
I am already testing it but I have not finished as I had to do other things

Quote
aba
you can render all values of one intSlider of (one or more) preset(s)


Good feature and option to have, although I still do not understand it right, could you please, explain it a little bit more how to use it and what you can do?

I mean that you have said that you can use one intSlider, so as far as I know it means that you can´t use any of the normal slider controls, so you must know which one of the settings is using a intSlider, if any is using it, and this can´t be known from outside, you must go inside Filter Editor and see it.
  Details E-Mail
Sharandra
Filter Forge Addict

Posts: 863
Filters: 26
Thx a lot aba, it works great now. Also thx for adding the int slider option. Maybe you could add the option to set values for the other intSliders in the future. smile:-)

Spaceray, the tool only lets you pick intSliders, so no need to know which ones are intSliders or Sliders.
And you can easily tell them apart from each other anyway, no need to open the editor. Sliders go from 1-100 seamless, while intSliders go in steps. smile;-)
  Details E-Mail
aba
Batchman
Posts: 95
I just found 3 minor bugs and solved them, please use the latest version (v095).

I have to look into the naming of the output images, something strange when testdriving. (only the names it works fine).

Quote
explain it a little bit more how to use it and what you can do?

As Sharandra says: you can only choose a intSlider. It will show how many steps it has. What you can do with it? I have a BW filter with 12 options in a intslider. With one preset I can try them all. If I like one I choose the render one step option to render the one I like the next time. Or I choose render one value of an intSlider which is connected to variation, no need to alter the preset. Or you can make a silly animation of it smile:)

btw if you want to see which controls and values the filter has you can look at the tab next to the presets tab when choosing a preset (choose select all presets to see them all). It als gives info about the lighting.

  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
Quote
Sharandra

Spaceray, the tool only lets you pick intSliders, so no need to know which ones are intSliders or Sliders.

And you can easily tell them apart from each other anyway, no need to open the editor. Sliders go from 1-100 seamless, while intSliders go in steps.


OH! thanks, is true that the intSliders go in steps instead of 1-100 values, you are right and is easy to identify them. For example when using the blend modes it goes in 20 steps and not in 1-100 values. Sorry I did not thought it this way.

Quote
As Sharandra says: you can only choose a intSlider. It will show how many steps it has. What you can do with it? I have a BW filter with 12 options in a intslider. With one preset I can try them all. If I like one I choose the render one step option to render the one I like the next time. Or I choose render one value of an intSlider which is connected to variation, no need to alter the preset. Or you can make a silly animation of it smile:)


OK, will try to make it and see what I can do, thanks
  Details E-Mail
SpaceRay
SpaceRay

Posts: 9762
Filters: 33
I want to thanks again for this awesome tool and is very good and useful

I have tested it with many things and have not found yet any error or bug more

And this changes the way you can use FF and how rendering the results can be done in a bettter and easier way, specially when you need more than one result of a filter and different presets, or multiple filters, multiple presets, or ...... smile:)
  Details E-Mail

Messages 91 - 135 of 234
First | Prev. | 1 2 3 4 5 | Next | Last 

Join Our Community!

Filter Forge has a thriving, vibrant, knowledgeable user community. Feel free to join us and have fun!

29,457 Registered Users
+17 new in 7 days!

137,909 Posts
+9 new last day!

13,448 Topics
+7 new in 7 days!

Online Users Last 5 minutes:

16 unregistered users.

Recent Wiki Edits:

Follow filterforge on Twitter